Thursday, September 4, 2014

Got the truck back today

All the main switches in the steering column have been replaced.  It's very much a 'shotgun' approach, trying to replace everything that might be behind the earlier problems, but as the dealer said, the only alternative was to go even more extreme and replace the entire cab wiring harness.  No problems surfaced on the short drive back from the service facility.  We'll see over the next few days whether or not this approach has worked.

Thanks again to everyone who offered advice.  I'll report back next week on whether it was the right advice!



Miguel said...

Glad we could help you....spend money? :D

Robert the Biker said...

Having similar problem (s)on my Jeep. I've traced it to a bad plug on the ECU (my problem is stalling) but also to bad earth connections, them being dirty and corroded. You might usefully check the earths too, thats free after all!

Anonymous said...

The dealer should have checked the earth connections and the wiring loom plugs while he had the vehicle...
He should also have checked the old parts to see if they were faulty..
If my mechanic suggested replacing the wiring loom i would replace the mechanic- with someone who knows what they are doing..

Old NFO said...

We're here to help! :-D

Anonymous said...

It sounds to me like your "dealer" wants to throw parts at it. Your shotgun approach comment is telling. I suspect a good auto electrician could solve your problem. The catch is finding that good one.

Most mechanics want to throw parts at a problem and hope it fixes it. Electrical issues do not tend to lend themselves to those solutions.

Two decades of marine electrical work have taught me this. A meter and schematic simplify things.

Good luck. I do appreciate your insights and read regularly.